MiQ appliance upgrade?

Just wondering, is there any documentation how to upgrade appliance ? eg. anand -> botvinnik ?

There’s a “upload a new product update”, but what that thing eats ?
Or is this possible at all ?


Thank you for the answer this was really helpful

Has anyone any information regarding this ? Just wondering if it’s always a clean install when doing major upgrades ?

1 Like

No tony

this is what i did

SSH into the manageiq appliance - the username root has the default password smartvm (you should change this password)
Change the protocol of git to https://
git config --global url."https://".insteadOf git:// 
cd /var/www/miq/vmdb
git pull
bundle install 
bundle exec rake evm:compile_assets
restart manageiq server

all done and i get the latest version of manageiq

Did you try that when upgrading to anand -> botvinnik ? That has worked for me as well when updating current release.

I’ve attempted this when updating an anand virt appliance, and after a reboot my Configure > About > version still reports:

Digging further, doesn’t appear the git pull actually brought down botvinnik bits. I’ve wrestled with git, but ineffectively.

I just used the procedure above, and though git seems to pull things, and though the rest of the procedure seems to work nicely, I still see anand-1.20150903102608_ea4c62a.

Is there another way to check to real version somewhere?

If you’re grabbing from git, and do git pull, you will still get the anand branch. You would need to grab the botvinnik branch instead with something like

cd /var/www/miq/vmdb
git fetch --all
git checkout botvinnik # or botvinnik-1 if you want the release tag

Then follow the rest of the steps for bundle installs and assets precompile

Wow, bad news…
I tried what you (Fryguy) suggested, but when checking out the botvinnik branch, git refused to checkout because of one file having changed.
Then I forced the checkout of the bot branch, and when running bundle install, an error message is telling that ruby below version 2.00 is not supported.
As I’m using the virtual appliance provided by ManageIQ into oVirt/RHEV, this one comes with a Ruby 193.
I then tried to upgrade my whole distribution (yum upgrade) and it seems to upgrade nicely.
After a reboot, I try again the same bundle install but this time, the binary is not even known (PATH issue I guess?).

Trying to find which binary bundle is (locate bundle|grep -v bundler|grep bin), I’m running /opt/rh/ruby193/root/usr/bin/bundle install and the error message is :

/opt/rh/ruby193/root/usr/bin/ruby: error while loading shared libraries: libruby.so.1.9: cannot open shared object file: No such file or directory

Is there a way to start from a clean git checkout and re-build everything, but without losing the database?

@neca I would think it would be a lot of work to upgrade your existing appliance to ruby200/postgresql94.

I’d recommend you try the latest devel image which uses ruby200/postgresql94 found here.

Note, you’d want to backup your certs/v2_key, config/database.yml, and database from the old appliance, and copy/import them into the new appliance. Postgresql 9.2 -> 9.4 requires you run pg_dump from the old appliance / pg_restore on the new appliance.

Is the manageIQ appliance now auto updating in capablanca-2?
Under Configure/About/Version I see everyday a new version with todays timestamp.
Todays example: capablanca-2.20160420094921_d083ab5


I also noticed this, but it doesn’t seem to be updating anything (I have no patches since Capablanca-2, and the ‘capablanca’ git branch seems to be untouched for several months).

Can anyone suggest a good way of adding the latest Capablanca-compatible bugfixes to a Capablanca-2 appliance? (the equivalent of updating to CFME 5.5.latest from a bugfix point of view).