MIQ (EUWE) error during Ovirt host refresh

Hi all,

I have an Ovirt provider in MIQ, the ‘Validation’ for host works, but if I’m trying ‘Refresh Relationships and Power States’ I get an error in log:

[----] E, [2016-12-03T16:36:46.835617 #3070:f89134] ERROR -- : MIQ(ManageIQ::Providers::Redhat::InfraManager::Refresher#refresh) EMS: [ovirt], id: [5] Unable to perform refresh for the following targets:
[----] E, [2016-12-03T16:36:46.835687 #3070:f89134] ERROR -- : MIQ(ManageIQ::Providers::Redhat::InfraManager::Refresher#refresh)  --- ManageIQ::Providers::Redhat::InfraManager::Host [myserver.mydomain.tld] id [4]
[----] E, [2016-12-03T16:36:46.842070 #3070:f89134] ERROR -- : MIQ(MiqQueue#deliver) Message     id: [230060], Error: [undefined method `detect' for nil:NilClass]
[----] E, [2016-12-03T16:36:46.842203 #3070:f89134] ERROR -- : [EmsRefresh::Refreshers::EmsRefresherMixin::PartialRefreshError]: undefined method `detect' for nil:NilClass  Method:[rescue in deliver]
[----] E, [2016-12-03T16:36:46.842322 #3070:f89134] ERROR -- : /var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:50:in `refresh'

Anybody can help me to identify the problem and how to solve it? The hosts are CentOS 7 with oVirt version 3.6 or 4.

Help will be appreciated :).

Hi @Radek,…please open an issue here
Please also supply the evm.log which is found here: /var/www/miq/vmdb/log

I believe @jprause meant this link for submitting an issue to the main repo.


Ugh! Yes, @jrafanie I did mean that,…hahahaha
Thanks! I suppose I’d been working in that repo and forgot.

1 Like

We akready have a BZ [1] for it.

[1] https://bugzilla.redhat.com/1393942

I am seeing the same error when I tried to add and refresh VMWare vCenter Hosts. Is there any way or work-around to fix the issue?