MIQ on K8S - manageiq-operator stuck

Hi everybody,
I am trying to deploy an MIQ on Kubernetes using the manageiq-operator using this documentation:ManageIQ
I have juste changed the “oc” commandline to “kubectl”

But unfortunately i am stuck because my manageiq-pod does not do anything.
I am pretty sur it is not accessing to Internet to pull the MIQ images but I don’t know how to troubleshoot deeper and how to solve this issue.

ac75008305@fedora
→ kga -n selfservice-hp

NAME READY STATUS RESTARTS AGE

pod/manageiq-operator-559c4f4d5-zl28t 1/1 Running 0 22h

NAME TYPE CLUSTER-IP EXTERNAL-IP PORT(S) AGE

service/manageiq-operator-metrics ClusterIP 10.98.77.34 8383/TCP,8686/TCP 22h

NAME READY UP-TO-DATE AVAILABLE AGE

deployment.apps/manageiq-operator 1/1 1 1 22h

NAME DESIRED CURRENT READY AGE

replicaset.apps/manageiq-operator-559c4f4d5 1 1 1 22h

ac75008305@fedora

→ % k logs -n selfservice-hp manageiq-operator-559c4f4d5-zl28t

{“level”:“info”,“ts”:1630506451.8407423,“logger”:“cmd”,“msg”:“Operator Version: 0.0.1”}

{“level”:“info”,“ts”:1630506451.8410807,“logger”:“cmd”,“msg”:“Go Version: go1.16”}

{“level”:“info”,“ts”:1630506451.8411088,“logger”:“cmd”,“msg”:“Go OS/Arch: linux/amd64”}

{“level”:“info”,“ts”:1630506451.8411276,“logger”:“cmd”,“msg”:“Version of operator-sdk: v0.17.2”}

{“level”:“info”,“ts”:1630506451.8421128,“logger”:“leader”,“msg”:“Trying to become the leader.”}

{“level”:“info”,“ts”:1630506453.4416852,“logger”:“leader”,“msg”:“No pre-existing lock was found.”}

{“level”:“info”,“ts”:1630506453.4884248,“logger”:“leader”,“msg”:“Became the leader.”}

{“level”:“info”,“ts”:1630506454.9984002,“logger”:“controller-runtime.metrics”,“msg”:“metrics server is starting to listen”,“addr”:“0.0.0.0:8383”}

{“level”:“info”,“ts”:1630506454.9992697,“logger”:“cmd”,“msg”:“Registering Components.”}

{“level”:“info”,“ts”:1630506458.1074219,“logger”:“metrics”,“msg”:“Metrics Service object created”,“Service.Name”:“manageiq-operator-metrics”,“Service.Namespace”:“selfservice-hp”}

{“level”:“info”,“ts”:1630506459.6260624,“logger”:“cmd”,“msg”:“Starting the Cmd.”}

{“level”:“info”,“ts”:1630506459.62788,“logger”:“controller-runtime.manager”,“msg”:“starting metrics server”,“path”:"/metrics"}

{“level”:“info”,“ts”:1630506459.6281784,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506459.7293901,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506459.8309927,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506459.932078,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506460.0338194,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506460.1350722,“logger”:“controller-runtime.controller”,“msg”:“Starting EventSource”,“controller”:“manageiq-controller”,“source”:“kind source: /, Kind=”}

{“level”:“info”,“ts”:1630506460.2360485,“logger”:“controller-runtime.controller”,“msg”:“Starting Controller”,“controller”:“manageiq-controller”}

{“level”:“info”,“ts”:1630506460.2361689,“logger”:“controller-runtime.controller”,“msg”:“Starting workers”,“controller”:“manageiq-controller”,“worker count”:1}

Is there a way to tell to the operator to use a private registry or to use another way to deploy a K8S MIQ?
Any help will appreciated.

Thanks a lot

@bdunne Can you help out here?