My chargeback report always empty


I tried to generate chargeback(* Base the report on) report, but it always shows empty. Meanwhile have checked the DB seems, MetricRollup table is empty. Can you please suggest me, how to get a chargeback rate cpu,data usage …

It would be greatful if some one help me

1 Like

Be sure you have “C&U Collection” enabled:
Configure > Configuration > Settings > Select CFME Region > C&U Collection

Hi Manel,

Yeah Aleady I have enabled the C&U collection. The problem here is that, while adding a chargeback report if I choose “Chargebacks” option from the * Base the report on dropdown, then this report shows always empty. For other options(Virtual Machines), displaying some records on the report.

I had the same problem, enabled C&U collection but reports are empty.
I tagged hosts and vm’s with customer name and environment.
The Solution was to enable “Capture C&U data” in the Categories.

Configure > Configuration > Select CFME Region > Select Categories > Select a category > Enable Capture C&U Data by Tag

That did the trick for me.

@Mike_Hulsman, tried that too but still its not working. Can you help me?

Did you add compute and storage rate assignments to items ?
And did you collect enough data to create the report.
The default filter is :
Show costs by “day” and Daily ending with “yesterday”, but you can change that in Daily ending with "Today (partial).
That will display the data collected today.
Otherwise wait until tomorrow and run the report again.


While “Add a new Report”, if I choose “Chargebacks” option from

  • Base the report on drop down, nothing is showing in the report. But If choose other options like “Virtaul Machine” then report shows actual records.

Is there any other special configuration or something should want to do for chargebacks report?

Also, is there any to get that report through API?

@Mike_Hulsman, do you have any idea about my above query?

Same thing here.

A VM is working in the environment and reports and chargeback info is generated. Same configuration in a development environment shows no data at all. We have updated the roles, and double checked that we are getting the information from C&U.

Is there any way of telling the appliance that we need to refresh the C&U data?


can you please some one guide us?


There were two things in our environment:

  1. I made the mistake of using the existing C&U user instead of adding a new one. Once I followed instructions and created a new user in CF, data started to work in my CF 3.2 up to date reference VM.
  2. For our development: Postgresql has to be at most 9.3, there are some things in MiQ code that modifies postgres that are not compatible with Postgresql 9.4. As that is the default one for Fedora 22, we needed to install manually 9.3 and tell dnf not to update it.

After that, reports are showing

I’m having same problem in 3.2 .
C&U server roles are active and C&U Collection is enabled.

@sergio_ocon what did you mean with:

What instructions you followed.


@gtanzillo any thoughts on this one? (After Sprint Review…)

I followed the documentation for CloudForms

I was making a mistake with the C&U collection, in the smae document explains what you have to do to enable C&U in RHEV, creating a new user in the postgres database.

i had a same problem before, i turns out that there are few data to generate a report, I waited for 3 days before I can actually have a chargeback report.

Unrelated to this issue, even though I have 2-3 weeks worth of data for chargeback, It will only generate 2 days worth of usage, I don’t know why.

I’m gotting the same situation the chargeback report just working for infrastrucutre providers like RHEV, Vmware.
When I try to use for OSP (provider), always comes empty.

I’m using CloudForms 4.1.
What’s going wrong with that ?