Not able discover vcenter

Just installed ManageIQ Gaprindashvili-3 ( as Openstack Instance ) and able to access the dashboard and configure EVM.

But when tried to discover a vCenter server - Compute > Infrastructure > Providers > Infrastructure providers, it is not getting discovered. I’ve provided the vcenter IP to discover.

Please help.

Try to add it instead of discovering.

I’ve even tried that. but no luck.

We’ve hosted this instance in our new openstack environment and I doubt it may be due to firewall blocking traffic. Could you please let me know which all ports need to be opened in firewall.

Does this help? TCP and UDP Ports required to access VMware vCenter Server, VMware ESXi and ESX hosts, and other network components

When you add the provider endpoint, does it accept your credentials (Validate)?

The only message I see in UI is “Credential validation was not successful: Unexpected response returned from Provider, see log for details”

When I checked the log ( evm.log ) I see execution timeout. Please see below.

[----] W, [2018-05-25T13:26:18.159117 #13429:131b57c] WARN – : MIQ(ManageIQ::Providers::Vmware::InfraManager.validate_connection) #<HTTPClient::ConnectTimeoutError: execution expired>

That’s a network problem: either routing, firewall or wrong IP/hostname.
Did you specify https?
Try to telnet from appliance to vcenter port 443.

I didn’t specify https. just gave vcenter IP/username and password.

Seems to be network issue only. Not able to connect port 80/443 of vcenter server.

Will work with network team. Thanks Xian for the help.