Often getting the error: Edit aborted! CFME does not support the browser's back button

Hi there,

Just to clarify.

I recently downloaded latest capablance-2 (after 15 Jan when it released) available appliance and in working with it I am getting an error when I browsing web interface. It sounds so:

Edit aborted! CFME does not support the browser’s back button or access from multiple tabs of windows of the same browser. Please close any duplicate sessions before processing.

This errors raises too often in many pages in particular within configuring Access Control options and Creating a provision dialogs. By my feelings it may happen every where. Of course I don’t have opened other tabs or windows with it. I use Google Chrome browser and Windows 7.

Please advise if I am alone with it and how it possible to be fixed.

Thank you,


I experience such kind of error too when navigating to Control->explorer, then Events accordeon, I select an event under “All Events”, then Configuration->Edit actions for this policy event.
I systematically get an error: “Unexpected error encountered” with some standard message on the possible cause.

Seems to be a server issue, as I tried with FireFox, Microsoft Edge and Chrome.
The error page includes:
Error text:
Couldn’t find MiqPolicy without an ID [miq_policy/x_button]

Not sure it’s the same error, as the error message is rather generic.


Hi @dm00,

Your issue should be resolved with the changes here:

@waeselyf - Hoping this fixes your issue as well. Please test and report back.



No does not solce the issue for me. I think the issue is of a different nature.
If I navigate from the policy accordeon:

  • define a policy,
  • define policy event assignments,
  • then from the policy I select an event assigned to that policy,
  • then I navigate to Configuration->edit actions for this policy event
    … It works.

But if I navigate directly to the events accordeon, select the event, then navigate to Configuration->Edit actions for this policy event, I get the afore mentionned error.

So I think yet it is a different error, and likely a bug. Navigation from the policy is a workarround.

But in fact, I’m not sure it is relevant to have this “Edit actions for this policy events” when navigating to control->explorer->event accordeon, because the action associated to the event is relevant in the scope of a policy. An event may be assigned to zero, one, or several policies. if it is assigned to zero policies, the menu is irrelevant. if it is assigned to several policies, then the menu is ambiguous. We should have first to selecct a policy the event is assigned to.

In the UI, when you navigate to Control->Explorer, then event accordeon, then select an event, you get a page where you see all the policies the event is assigned to. Then if you click to a policy, you navigate to that policy, where you can edit actions for the event.


I think it’s caused by some stray onclick handler that’s added multiple times causing the affected buttons to fire more than 1 request per click…