OpenStack integration works unless provisioning instance

Hi, I’ve installed ManageIQ and managed to add OpenStack Cloud Provider with v2 keyston/non-ssl. After that all the data from OpenStack was present in ManageIQ. I also managed to perform lifecycle operations on instances: stop VM, reboot. The problem is when I try to create instance I get [MiqException::ServiceNotAvailable]: MiqException::ServiceNotAvailable. There is also no request for Nova (which is strange because with other operations there is no problem). What do you think about this kind of situation when integration is working for everything except instance creation?

Hi @Stanislav_Khalup,…I’m trying to reproduce the issue you described. While I do that,…can you let me know the version of ManageIQ you’re using? Go to Settings and About. The version is listed there.

I am using the latest stable version that is provided

Thanks @Stanislav_Khalup. While I’m not seeing the same error as you described, I am seeing something strange. @gmccullough I provisioned an Openstack instance, and it says it was successful, but when I review the Openstack instances, I don’t see the instance I just provisioned. Any ideas?

As an aside and maybe another issues, originally I had Openstack and GCE as providers. When I tried to provision an Openstack instance, I can only choose GCE templates. I removed the GCE providers so I could try and reproduce the issue Stanislav described.

@Stanislav_Khalup after testing this again,…I was able to provision an Openstack instance and this time I didn’t run into any anomalies (which were more than likely my fault).

Can you describe the exact steps you are performing. Example:

  • In left panel select Compute, Clouds, Instances
  • Selected Openstack under Instances by Provider
  • Clicked on Lifecycle, Provision Instances
  • Selected an Openstack Image,…and stop there.

I’m asking for this since there’s another way to get to this same scenario. I’d like to make sure we’re on the same page.

Can you also provide a screen shot of the Services, Requests page. This should show the request that failed for you and perhaps further details.

Might want to check the MTU size on the appliance is set to 1400 and not 1500. Have see this happen with a static IP configuration of the appliance in OpenStack leading to communication issues when larger bandwidth is required only. Sounds similar. Check “ip a” output…

1 Like

@Stanislav_Khalup could you paste the whole stacktrace of the error from the log/evm.log?