Provisioning Timeouts 50-70% error during placement - CFME/Vcenter

Using CFME and Vcenter to provision VM’s from Service. It works fast and well in our lab. In production, we have error rate of 50-70% during placement. Sometimes it goes/ sometimes no’s. No real error but seems to timeout during placement. We have tried adding in retries to extend timeout but still no luck. The only difference between lab and production at this time is the amount of hosts attached to Vcenter. We have placed Provisioning Scope - All on the hosts we utilize for CF. Anyone have any tricks?

Hi Michelle

The ‘Provisioning Scope - All’ tag is only used with the ‘vmware_best_fit_with_scope’ placement method, which is in the RedHat automate domain in CloudForms. Which placement method are you using? The out-of-the-box default for VMware is ‘vmware_best_fit_least_utilized’ in the ManageIQ domain, so unless you’ve explicitly changed this your prov_scope tags will not be referenced.

Hope this helps,

Hi Peter,

I appreciate the response. Yes we are using vmware_best_fit_with_scope for placement. I increased the memory for generic workers but that seemed to have no effect on the timeout. It starts looking for best fit until it times out.
The vmdb appliance has 12GB RAM but seeing some swapping happening so I am looking at increasing to 16GB. I’ve just learned about the vmdb maintenance scripts and researching that. That’s all I have so far.

Any other thoughts?

Thanks again,

I just wanted to follow up with this in the off chance someone else runs into this issue. This issue was resolved by adding a new Vcenter and removing the old one. We had over 1800 guest vms on the initial provider which I believed impacted the length of time it took to sort and determine placement. The large majority of those VM’s were not in scope for our use with CF’s. Additionally, I think we may have been able to resolve this by adding more workers (N +1) 1 worker for 300 guest vms. We chose to move to a new Vcenter for CF’s use only so I can’t confirm that.