"rsync" could not be found on your PATH

My OS is windows 10 64 bit. I try to implement manageiq with vagrant commands like below.

vagrant init manageiq/euwe
vagrant up

But making virtual machine failed. This is the error message.

“rsync” could not be found on your PATH. Make sure that rsync
is properly installed on your system and available on the PATH.

I am stuck here. Any help will be deeply appreciated. Thanks

@jhwang I haven’t used vagrant on windows but if it’s trying to use the system rsync on windows, I highly doubt that would work even after getting past this error. While ruby is cross platform for most things, there are many places in the ManageIQ codebase that assume a unix-like system. Our server process forks workers, which is not supported on windows.

Can you explain what you’re trying to accomplish? I’m afraid getting ManageIQ running well on windows will be a frustrating experience.


1 Like

Thank you for your reply. My os was windows 7 32 bit, and as you know, docker machine can’t be installed on 32 bit windows. So i had no choices. But the worse was vagrant manageiq box conatined a lot of bugs. So i will update my os and run manageiq on 64 bit docker machine.
Any way I appreciate your nice advice. Thanks. :slight_smile:

This worked for me… I’m running windows 10 and was trying to share folder between my machine and a centos7 vagrant box, I was getting same error as you, link below has more info but essentially added rsync.exe to “C:\Program Files\Git\usr\bin”, after this rsync was available in Git- Bash for windows shell, and I received the below on my “vagrant up”:
==> default: Rsyncing folder: /c/HashiCorp/Vagrant/centos7/ => /vagrant

Ref Link: https://blog.tiger-workshop.com/add-rsync-to-git-bash-for-windows/