SmartState analysis failing on ISCSI in ovirt/RHEV

Hi there,

I attached to my MIQ appliance vm an iscsi lun in readonly.
if i ssh in my appliance and do pvscan, i can see the device (/dev/vdc)

PV /dev/vdc VG ef25aa99-4ae9-4b41-a906-cd18f03afaa9 lvm2 [299.62 GiB / 63.38 GiB free]
PV /dev/vdb1 VG vg_data lvm2 [40.00 GiB / 0 free]
PV /dev/vda2 VG VG lvm2 [39.50 GiB / 0 free]
Total: 3 [379.12 GiB] / in use: 3 [379.12 GiB] / in no VG: 0 [0]

When i try to run a SmartState analysis on a vm that resides on this iscsi lun, i get this errror :

Unable to mount filesystem. Reason:[No root filesystem found.] for VM:[/rhev/data-center/00000002-0002-0002-0002-00000000038b/mastersd/master/vms/8b016110-d104-4f97-8b84-5cd686008b08/8b016110-d104-4f97-8b84-5cd686008b08.ovf]

What can i do to fix that ?

What operating system is the VM running?

RHEL 7 and Fedora 20.

But just tried with one that has RHEL 6 and it worked.

So i guess those OS are not supported yet …

XFS isn’t support yet, but should be in a fixpack pretty soon (I hope).

What version of ManageIQ are you running?

@mlessard make sure you credential the hosts and set the CFME appliance relationship to the vm that is the appliance. FYI, cfme relationship being set is only a requirement when working with rhevm vm scanning, its not required for vmware.