SmartState Analysis failing on VMware vms

I am running the current anand appliance with vcenter 5.5.0 and esxi 5.1.0. I have installed vddk 5.5.3 on the appliance. I have set the host credentials for my esxi hosts and set the smartproxy and smartstate analysis roles for my appliance. I can successfully run the smartstate analysis for the esxi host. however when i run a smartstate analysis for one of the vms i get the following error:

No eligible proxies for VM :[[prfosm-nas] mwiqtest1/mwiqtest1.vmx] - [No
active SmartProxies found to analyze this VM], aborting job

any ideas on where to start looking to determine what the problem is?

After running the install for the vddk did you run ldconfig?

yes i ran ldconfig and for good measure restarted the appliance.

I am struggling with the same topic. I did run the ldconfig and also verified that the lib could be found…

[root@localhost log]# ldconfig -p |grep vix (libc6,x86-64) => /usr/lib/ (libc6,x86-64) => /usr/lib/

First ensure that the SmartState Analysis and Smart Proxy roles are checked. If so then try installing the vddk from VMware-vix-disklib-5.1.3-1890807.x86_64.tar.gz and rerun ldconfig.

So it is not supported with VMware-vix-disklib-5.5.0-1284542.x86_64.tar version?

I used VMware-vix-disklib-5.5.2-1890828.x86_64.tar last week and it worked fine but each environment is different. I am not sure what causes this. I always start with the latest 5.5 and if that doesnt work i back-rev it to latest 5.1 as a fail-safe.

i have tried 5.5.0, 5.5.3, and now 5.1.3 and all give the same no elgible proxies for VM. i guess i will try 5.5.2

5.5.2 failed with the same errors.

under configure->smartproxies should there be any listed? i have no records found. just to see i tried the add a new smartproxy and in the dropdown “name (from chosen host)” it is empty.

In my Cloudforms installation that I am comparing ManageIQ with, there is a VM listed in that drop down. I don’t know how that was done, I am trying to figure out the same thing. The Cloudforms installation was not done by me and I have nobody to ask about it…

No there shouldnt be anything there. That is for something different. You need to ensure that the roles are checked as shown in the attached image.

ok. yes the roles are checked in my setup. smartstate analysis succeeds when running for an esxi host.

are there any logs i can dig into to find a more specific error? the only info i see is in the evm log which is just the no proxies found error.

Yes look in the /var/www/miq/vmdb/log/evm.log file for errors

well i have looked through the evm.log file and can not find any other info that is helpful. only the line that says no eligible proxies for vm.

Can you send a screenshot of your server with the roles and the tree view like i did? Also screenshot your vmware provider summary screen?

Are there any lines in the log that begin with:

VixDiskLib_raw: failed to load

In the advanced settings, where you edit in yaml, what is your scan_via_host value?

If it’s true, I believe you need to have an esx host with access to the vm’s storage and provide the host’s credentials.

It’s usually easiest to navigate to the vm in the UI, go to it’s host, validate the credentials for this host, ensure the roles mentioned above are enabled and try again.

If this all checks out ok, then look for vix errors as mentioned above.

Also, are you able to analyze other vms?

there no VixDiskLib errors.

scan_via_host is true and i have the credentials for the esxi host setup. the esxi host has access to the storage where the vm is hosted. it is local to the esxi machine. i have also tried scan_via_host = false but the smartscan still fails with the same errors.

smartscan fails on all vm’s. have never been able to get this to work.

is there any correlation in the processes/settings in running smartstate analysis on the hosts, datastores, and vms? i have done some more testing and i can successfully run a smartstate analysis on all the datastores and hosts however it fails on all the vms present.