SOLVED: Credential validation was not successful: Timed out connecting to server

I am:

  • Setting up a new dev instance of miq.
  • Adding An Azure provider.
  • getting the error in the subject line

I tried: creating an Azure AD application and service principal that can access resources. I got the client id ok. I am sure the subscription and tenant id are fine. I think the issue is the client key.

Per the microsoft docs above one can use either a certificate based authentication method or a password-based authentication method, which involves creating a secret in your app registration. It was easy. But when I load that secret in MIQ and try to validate it. I get the error mentioned above.

The logs say Timed out connecting to server.

Any pointers out there? Thanks all. I know I ask a lot of questions.

Generally if the credentials are wrong you would get an authentication error, not a timeout. Are you able to connect with the command line tool?

az login --service-principal -u <client_id> -p <client_key> -t <tenant_id>

Thanks @djberg96 : ) Great point! I’m trying to get the azure cli installed to test that. So far it’s giving me grief with a connection actively refused bug. I’ve opened an issue on github.

@michaelbutak Is there a proxy and/or NTLM involved at any point?

@djberg96 Yeah, it was the proxy. I forgot to set that up. It’s usually something simple, isn’t it? Now miq is authenticating with Azure just fine. Thanks for the help!