SOLVED - Error on Ubuntu while preparing Euwe development system


I’ve been trying to develop on an Ubuntu based distro. I managed to prepare the OS with all the dependencies needed by Rails and ManageIQ. I followed the Fedora guide to mimiq equivalent apt’s for the different yum’s mentioned there.

However, after cloning the main repository, and after changing to the Euwe branch, and pulling, i’ll get the following error:

ruby@ruby-VirtualBox:~/projects/manageiq$ bin/setup
== Installing dependencies ==
Updating bower assets in parallel...
The Gemfile's dependencies are satisfied

== Copying sample files ==

== Preparing database == (at master@040ac28) is not yet checked out. Run `bundle install` first.
== Command ["bin/rails db:create"] failed ==

Some details about my run-time:

ruby@ruby-VirtualBox:~$ ruby -v
ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]
ruby@ruby-VirtualBox:~$ rails -v
Rails 5.0.1
ruby@ruby-VirtualBox:~$ bundle -v
Bundler version 1.14.4

I have not been using split repos (no

Needless to say that I’ve tried bundle install. Anyone got any idea what is wrong?

Hi, very probably, that’s just missing dependencies - header files most likely. If you tried to install that gem manually, you’d probably see more info.

We currently don’t have developer instructions for debian-based systems, but @romanblanco created an initial version of these some time ago:

Should help :slight_smile:

1 Like

Resolved! Thanks for hinting me to the work of @romanblanco. My script pulls the external libraries more or less in the same way into the OS as he does, but I skipped a npm package. Now I am able to run ManageIQ on Lubuntu 16.04.2 LTS. I will tweak and verify the script a bit more, and put it on Gist later.


@mud500 Glad you’ve figured out the issue, I’ll gladly update the script I have on Gist, after your changes :slight_smile: