[Solved] Excon::Errors::Timeout

Hi everyone,

After successful connection to my Cloud_provider (OpenStack), I got a next problem in the fog.log:

[----] E, [2015-03-05T19:20:16.844842 #28320:977e94] ERROR – : excon.error #<Excon::Errors::Timeout: connect timeout reached>

And I can’t recive an info in section “Relationships” =(((

Connection with prowider 100% alive, no firewalls or anouther obstacles.

Does anybody have any ideas?

Can you post the full error from the fog.log and the related openstack error in the evm.log ?

The reason was that Keystone returned a link to another parts of infrastructure,which were unavailable for ManageIQ. I catched it with tcpdump. Anyways, log absolutely informless =(( Cause I thought that ManageIQ communicates only with Keystone

Ah, the way it works is that ManageIQ talks to Keystone initially, and Keystone returns a list of all the other endpoints. Then, it talk to those endpoints directly to get the necessary data.

So what is the fix to this error after all?

You must provide ManageIQ access to all the discovered endpoints. Enable debug logging for fog (Configure > Zone Settings > Advanced) and check the fog.log to see which endpoint is timing out.

I wrote from examples some fog code and with the EXCON_DEBUG=true env var could see exactly what was going on. In my case the publicURL endpoints were published in the external network and the admin and internal where published on the internal network. The Keystone handshake begins by using the user name and password against the publicURL then with the authorized token it switches to the adminURL for further queries. So it is paramount that all endpoints be accessible from the ManageIQ VM which typically runs within the Openstack that it manages.

Hi, I’m having the same problem.
I’ve deployed ManageIQ VM (version botvinnik-1) in a MOS 6.0 cloud.
I’m trying to add the same OpenStack cloud under the MangeIq control.
From Cloud Providers I’m able to get credential verified but I’m not able to see anything in the relationships. Looking at fog.log (with debug enabled) I’m having ERROR – : excon.error #<Excon::Errors::Timeout: connect time-out reached>.
For what I’ve understood a first request is issued to keystone public endpoint which returns all services endpoint list. After this request a second request is issued to the glance internal endpoint (Host"=>“”) which is unreachable.
It seams like some networking problems are occurring. Could you suggest any solution? The documentation about ManageIq VM network configuration in openstack doesn’t tell anything. Is it needed to connect the ManageIq vm to some particular network i.e. a provider Network?

Keystone endpoints - check adminurl endpoint? Is it set properly (not localhost or something else?) Maybe you could try to make the a call to keystone with curl (from the ManageIQ mashine) using the the same credentials (username/password) and see if you can get response full of data. Maybe this is connected (Using cloud providers (Amazon, OpenStack)).

Hi, I have followed the intruction to patch the file /var/www/miq/lib/openstack/openstack_handle/handle.rb

reported at the post [Solved] Problem with new EMS Cloud and the problem was fixed now I’m able to connect manageIQ with my openstack cloud. Thanks for support :smiley: