[SOLVED] Unable to get provisioning profiles working

I’m running a fresh deployment of anand-1 OVA and I’m having trouble getting provisioning profiles to work as part of setting up custom provisioning dialogs.

I’ve been following the ManageIQ Anand Lifecycle and Automation guide and also the CloudForms Management Engine Lifecycle and Automation guide (which, incidentally, seems to be more accurate than the ManageIQ guide).

  • My vCenter provider is configured and working.
  • The Automation Engine role has been enabled.
  • LDAP auth is configured and working.
  • A group “TestDept” exists with a role copied from EvmUser-user_self_service.
  • I have a user in the TestDept group that can log in successfully.
  • I’ve created a custom provisioning dialog file called “miq_provision_dialogs-TestDept.rb” and placed it in /var/www/miq/vmdb/db/fixtures/.

The provisioning profile instance for TestDept is set up like so:

The dialog_name field is set to miq_provision_dialogs-TestDept.rb.

However, I can’t seem to get the custom dialog to display when logged in as my test user. The default dialog is shown instead.

Am I missing something obvious?

Looks like that portion of the documentation needs to be updated. The dialogs now live in the database and you can create/copy them in the UI under Automate -> Customization -> Provisioning Dialogs.

Once a provisioning dialog is created, how do I tell the system that I want to use it? Do I just refer to it by name in the provisioning profile?

Yes, you need to refer to it by name in the profile. Drop the .rb from the dialog_name field and I think it should work.

@gmccullough That worked, thanks!