Unable to pass IP address info from provision diag to RHEV

Hi! I am looking for help.


IP address info on miq provision dialog is not being passed to RHEV.

Guest image spins up without ip, dns, and other info.

I am assuming cloud-init info is not being passed. Maybe I am doing something wrong?

I have also tried putting in gibberish for the ip address values. No change.


RHEV version: (latest stable from Red Hat)

ManageIQ: latest from git 20150727

Updated via MiQ appliance upgrade?

Guest OS attempting to be provisioned: CentOS 7

[root@localhost ~]# cat /etc/redhat-release
CentOS Linux release 7.1.1503 (Core)

cloud-init log from guest os:


Screenshot of the ip address / dns info that is not being received on provision:

http:// i.imgur.com/Ecd1Jxu.png

(remove space after http://
miq board will not let me link images)

I did see this post:

Perhaps cloud-init to rhev / ovirt is not supported at this time?

Hi Scott, there is currently a bug on this and it should be resolved soon. https://bugzilla.redhat.com/show_bug.cgi?id=1238390

Edit: the ‘nightly’ development .ova appears to be very old. Can anyone confirm?

I am trying the latest miq devel .ova. Would this have those changes incorporated?

The cloud-init.log on my CentOS 7 test vm says ‘no instance datasource found’. cloud-init stuff is not being passed from the miq provision dialog to rhev.

miq rhev devel ova from 20150901

I did a git pull from master for the latest miq.

Still not working, in fact worse.

This time, there are no cloud-init logs on the guest vm. It is as if miq did not attempt to use cloud-init to pass in the configuration.

CentOS 7 template
miq from master 20150902

Let me know if I can provide more logs or information.

rhev appears to look for the cloud-init datasource in an odd place, a floppy!


This still does not work for me in miq. Does the latest stable have the fixes from that bz?

I am now trying the latest miq stable:


What results when trying to provision CentOS 7 from a template to RHEV is:

  • A powered off vm (even after you select ‘power on after creation’)

  • No static ip info nor other info (ex root password) being passed to the instance

Thank you for your help,

Hi Scott,

Yesterday I was workin on a setup that matches what you described (oVirt Engine/Node), VM with CentOS 7 deployment from a template within oVirt (including cloud-init, e.g. setting hostname & resetting SSH keys etc) was successful, but the same exercise from within ManageIQ didn’t work.

It has been verified that the same script (cloud-init) that was working fine within oVirt was being passed down from ManageIQ -> oVirt, but none of the operations has been carried out.

From searching here, this doesn’t appear to be solved in any way, nor any complete documentation appears to exist.

Have you been able to resolve this issue by yourself and if yes could share what had to be done?

I have to admit that this is kind of a frustrating experience, as there aren’t even error messages that one could troubleshoot (at least none were seen).

Thanks for your efforts to reply,