VMW Provider - Incompatible device backing specified for device '0'

Hi All,

I am using a VMW 6 provider.

The workflow completes to the point of cloning the Ubuntu template (it includes perl/net-tools/vmware-tools 9.10+) and then after cloning completion, VCenter gives the above mentioned error:

Incompatible device backing specified for device ‘0’.

All the networks available match the one requested, however we end up with a powered off vm, and no NIC connected.

The Options Hash is populated as expected.

A VCenter Clone to VM using the associated Customization Profile, gives a well customized VM.

Where should we start debugging?


Hey @tkonto incompatible device backing could also refer to a virtual disk in addition to a virtual nic. Try provisioning your VM without any disks then without any NICs so we can try to narrow down which class of device we are talking about.

Hi @agrare.

Thank you for your time on that.

It is the NIC. Sorry not to mention that from the beginning.

Now the problem is pinpointed the VLANs naming.

Going from Approval to Provisioning, the options hash does not get populated with the vlan value.

The default infoblox method is expecting a NIC index and an associated VLAN name on that index.

The automated call does not populate the vlan based on what was manually selected from the provisioning catalog.

We also tried to manually feed into the instance a VLAN name matching the ones discovered by MIQ, however we end up in the creation of a similarly named VLAN in VMW cluster, rather then actually connecting the VMs NIC to the stated Port Group.

Which element holds in the DB the actual VLAN / PortGroup names?


Ah okay, so the VLAN/Portgroups are stored in the Lan model and uid_ems is the column name we use. If you are provisioning a dvpg you need to add an is_dvs: true to your automate object.

Hi @agrare

Any (personal or best practice) preference in where to place it?


http://manageiq.org/docs/reference/latest/doc-Methods_Available_for_Automation/miq/index look for set_network_adapter and is_dvs

It worked.

Actually my issue is related (but not the same) to https://bugzilla.redhat.com/show_bug.cgi?id=1508069


In the (copied to a custom namespace) infoblox_aqcuire_ipaddress method we changed the network_settings hash build to look like

# build network_ settings hash
adapter_settings = {
  :network => get_network_vlan(nic_options, infoblox_network_hash),
  :devicetype => get_network_devicetype(nic_index, nic_options),
  :is_dvs => true,
  :mac_address => ipv4addr[:mac]

We added " :is_dvs => true,"

Now it works and the VLANS are matched to DVSs, the VM is provisioned with the NIC connected to the correct PG and customization concludes.

Thank you All for reading.

Thank you @agrare for your comments.


Yay! happy you got it working @tkonto