Widgets generating incorrect content


We’ve set up an MIQ environment running on RHEV, Hyper-V and VMware and a few widgets generate old information on the dashboard. For example our “Virtual Infrastructure Platforms” should tell us we’ve got 5+ VMware hosts, 2 RHEV hosts and 2 more Hyper-V machines. Somehow it only displays the RHEV hosts in the charts.

We’ve added providers for all our environments, and I can see the hypervisors within ManageIQ. But we still get incorrect information of these widgets… But if I try to get this widget to fullscreen, I’ll get the correct information in these tables below…

Aside from the issue above we also keep getting VM’s being top storage users even though the actual VM is non-existent anymore. However the disks used in the past are still on their original datastore because they are used on a new VM. Also I really want to ad a function to our dashboard that we get the top 10 most expensive VM’s. Now it just sorts based on the name of the VM, can I change this?

EDIT: Solved the sorting by downloading the .YAML file and manually changing the ‘sortby’ option. After that just upload the same file again…

Last question a bit easier one I think: I have created a button that extends our retirement date of the VM’s, if a user would press this button. Will they be notified by default, or do I need to configure some additional parts? Would a user extending their retirement date be notified again if they extend pas the 2 weeks/1 months notification time?


Hi Kevin,

For the chart issue, I don’t see that happening in my environment, the chart contains all of the platforms. Perhaps @martinpovolny or @PanSpagetka can chime in here to determine if this is a bug we need to fix.

On the retirement extension button and re-notification of the new retirement date. If the user is getting notified on the initial date, then I think they will get re-notified when the new date comes up. @gmccullough, can you confirm?

. . . Dan

Hello Kevin,
To fix your issue with widget chart, try re-generate this widget. Go to Cloud Intel => Reports => Dashboard Widgets => Select widget you want to re-generate in tree => Configuration => Generate Widget content now

This should fix your issue, if it doesn’t i will look at it.