Windows clone from Vmware and OS customization getting failed

Hi,

I am using VMware as a provider, For the IP, using external IPAM.
Right now using PXE boot installation for both Redhat Linux and Windows with samba configuration with windows image, both windows and Linux VM will have total 3 NIC (2 static IP and 1 with dhcp)

Now just exploring with VM cloning method for both Redhat Linux and Windows 2012r2 servers provisioning from template.

Just followed the below listed items:

  1. Created the VM Customization Specifications in VMware for both Linux and Windows.
  2. Created the VM with just a base OS installation and converted it as a template for both Linux and Windows.
  3. Linux, Created a Catalog in MIQ with template and Customization Specifications. And selected a “Override Specification Values in customize”
  4. Windows, Created a Catalog in MIQ with template and Customization Specifications. And selected a “Override Specification Values in customize” and uploaded the Sysrep text file

For Linux server, I can able to provision the VM successfully with auto hostname configuration and IP configuration (total 3 NIC, 2 static IP and 1 with dhcp) without any issues.

For Window server, VM clone is happening successfully. But hostname and IP assignment is not happening. I can see the error in automation log as “Cannot complete customization”.

Suspecting that I am missing something in sysrep file or in Vmware Windows Customization Specifications, since it was working fine for Linux.

Not sure what I missed.